提示2:更好的默认设置

Vim是VI的改进版本。 它具有更好的默认选项和更易用的可用性,但是默认情况下它与旧的VI不兼容。

为了确保我们使用Vim默认值(而不是VI默认值),我们需要在配置文件中添加nocompatible选项:

 设置不兼容 

这是一个很好的起点,但我们可以做得更好! 我们可以手动设置一些其他有用的选项:

  • 能够在插入模式下通过任何东西使用退格键
  • 无需按回车键即可在缓冲区中搜索文本
  • 激活语法识别
  • 激活自动缩进
  • 使用UTF-8编码

所有这些选项似乎都是一个很好的标准,但在Vim中默认情况下未激活。 幸运的是,蒂姆·波普(Tim Pope)创建了一个软件包来设置它们,并使我们的Vim配置稍微好一些:Vim-Sensible。

要使其工作,我们只需要安装此插件:

 插入'tpope / vim-sensible' 

现在,我们准备使用简单但不错的VIM配置。